Subject: A Major Milestone

From: dwells (Don Wells)
Date: Wed, 16 Feb 94 17:09:06 EST

Dear Bob and Hans-Martin,

I have integrated Hans-Martin's resource records with mine.  There are
duplicate records to be pruned, various classifications that need to
be changed, and text to be added/deleted/revised, but the bottom-line
fact is that my new pages are no longer just my work, they are a union
of the two previous sets of pages.  I have revised my home page to
reflect this fact. The new introductory text also has a pointer to
STScI.

I have deleted my temporary files and old versions, and have committed
myself fully and irrevocably to the new system.  I am pleased with the
way the <DT> format has worked out. Several recent new resources
received by Email included paragraphs of text description, and I just
put these into <DD> fields. A few minutes ago I wanted to check the
classification of a resource, so I clicked on it, got its home page,
which began with a historical overview paragraph. I cut that paragraph
out of the Mosaic window and dropped it into the <DD> field intact.
This system works.  I have not yet installed OWNER records; that will
be hard work, and will take a lot of time.

The combined STECF-NRAO database is 262 records totalling 55.8_KB, and is:

     http://fits.cv.nrao.edu/www/yp_master.html
      ftp://fits.cv.nrao.edu/fits/www/yp_master.html

I intend to add configuration-option features to dtsplit until it can
make pages that are similar to the current STScI and STECF pages.
Also, I am still working on dtdiff in the background.

Should I proceed to integrate the STScI records with the STECF-NRAO
merged database? If "yes", what anonFTP address? I really like the
<DD> paragraphs that many of the STScI resource records have! (the
WAIS engine will like them too)

I append the 'make install' output for the run that did the final
merger of the two databases. 

Best Regards,
Don

 -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

cd /fits/dwells/ftp/fits/www/astroweb/
make -k install
touch temp_tail.html
/home/fits/dwells/bin/getdate.awk temp_tail.html > temp_tail.html;
cat merged.html master-hma2.html | dtsort -v tail=temp_tail.html >yp_master.html
dtsort executed by dwells on fits.cv at Wed Feb 16 14:40:37 EST 1994
 305 resource records read.
 179 passes needed by bubble sort.
   0 identical resource records deleted. (n=305)
  41   similar resource records  merged. (n=264)
 167 resource records edited:
	   4 cases of |</b>|
	 159 cases of |<a |
	   4 cases of |<b>|
	 167 cases of | href=|
	   1 cases of |<br>|
	  10 cases of |</a>|
   2 lines copied from temp_tail.html.
 264 resource records written.
dtcheck <yp_master.html
 267 blocks checked,    0 match failures.
ls -lg merged.html yp_master.html
-rw-r--r--  1 dwells   aipspgmr    29935 Feb 16 13:53 merged.html
-rw-r--r--  1 dwells   aipspgmr    55520 Feb 16 14:41 yp_master.html
dtsplit <yp_master.html
 264 resource records from input
  15 records >> temp_radio.html
  27 records >> temp_optical.html
   5 records >> temp_space.html
   3 records >> temp_solar.html
  26 records >> temp_center.html
   3 records >> temp_infosys.html
   6 records >> temp_agency.html
  11 records >> temp_dept.html
   2 records >> temp_society.html
   2 records >> temp_survey.html
  18 records >> temp_text_search.html
  11 records >> temp_newsgroup.html
  30 records >> temp_software.html
   1 records >> temp_document_tools.html
  15 records >> temp_preprint.html
   6 records >> temp_abstracts.html
   6 records >> temp_full_text.html
   5 records >> temp_bibliography.html
   2 records >> temp_library.html
   3 records >> temp_other_library.html
   3 records >> temp_people.html
   2 records >> temp_jobs.html
   6 records >> temp_meetings.html
   4 records >> temp_astroweb.html
  16 records >> temp_other_astronomy.html
  20 records >> temp_pictures.html
   5 records >> temp_weather.html
  14 records >> temp_protocols.html
   4 records >> temp_misc.html
 ----------------------------------------------------
   0 unrecognized category codes:
 ----------------------------------------------------
          temp_radio.html >> yp_observatory.html
        temp_optical.html >> yp_observatory.html
          temp_space.html >> yp_observatory.html
          temp_solar.html >> yp_observatory.html
         temp_center.html >> yp_observatory.html
        temp_infosys.html >> yp_observatory.html
         temp_agency.html >> yp_observatory.html
           temp_dept.html >> yp_observatory.html
        temp_society.html >> yp_observatory.html
         temp_survey.html >> yp_observatory.html
    temp_text_search.html >> yp_text_search.html
      temp_newsgroup.html >> yp_newsgroup.html
       temp_software.html >> yp_software.html
 temp_document_tools.html >> yp_software.html
       temp_preprint.html >> yp_library.html
      temp_abstracts.html >> yp_library.html
      temp_full_text.html >> yp_library.html
   temp_bibliography.html >> yp_library.html
        temp_library.html >> yp_library.html
  temp_other_library.html >> yp_library.html
         temp_people.html >> yp_people.html
           temp_jobs.html >> yp_people.html
       temp_meetings.html >> yp_people.html
       temp_astroweb.html >> yp_astroweb.html
temp_other_astronomy.html >> yp_astroweb.html
       temp_pictures.html >> yp_pictures.html
        temp_weather.html >> yp_misc.html
      temp_protocols.html >> yp_misc.html
           temp_misc.html >> yp_misc.html
ls -lg temp_*.html
-rw-r--r--  1 dwells   aipspgmr      123 Feb 16 14:40 temp_tail.html
ls -lg yp_*.html
-rw-r--r--  1 dwells   aipspgmr     3012 Feb 16 14:42 yp_astronomy.html
-rw-r--r--  1 dwells   aipspgmr     5060 Feb 16 14:42 yp_astroweb.html
-rw-r--r--  1 dwells   aipspgmr    11216 Feb 16 14:42 yp_library.html
-rw-r--r--  1 dwells   aipspgmr    55520 Feb 16 14:41 yp_master.html
-rw-r--r--  1 dwells   aipspgmr    29046 Feb 14 10:33 yp_master_old.html
-rw-r--r--  1 dwells   aipspgmr     5710 Feb 16 14:42 yp_misc.html
-rw-r--r--  1 dwells   aipspgmr     3131 Feb 16 14:42 yp_newsgroup.html
-rw-r--r--  1 dwells   aipspgmr    20213 Feb 16 14:42 yp_observatory.html
-rw-r--r--  1 dwells   aipspgmr     2075 Feb 16 14:42 yp_people.html
-rw-r--r--  1 dwells   aipspgmr     4209 Feb 16 14:42 yp_pictures.html
-rw-r--r--  1 dwells   aipspgmr     3317 Feb 16 00:37 yp_protocols.html
-rw-r--r--  1 dwells   aipspgmr     6376 Feb 16 14:42 yp_software.html
-rw-r--r--  1 dwells   aipspgmr     3546 Feb 16 14:42 yp_text_search.html
rm -f ../yp_*.html
cp -p yp_*.html ..

Compilation finished at Wed Feb 16 14:42:34

---

From: dwells (Don Wells)
Date: Sun, 20 Feb 94 00:07:22 EST

Bob Jackson writes:
 > file://stsci.edu/html/net-resources.html
 > file://stsci.edu/html/net-software.html
 > file://stsci.edu/html/net-publications.html

DONE -- with the exception that the CATEGORY codes are not complete
yet. All of the indented records havve been eliminated. Here is output
from the last run, with 405 resources and 106 KB:

cat merged.html master-stecf.html net-software.html net-publications.html  net-resources.html \
		| dtsort -v tail=temp_tail.html -v keys=yp_keys.html \
		>yp_master.html
dtsort executed by dwells on fits.cv at Sat Feb 19 23:45:23 EST 1994
 405 resource records read.
   1 passes needed by bubble sort.
   0 identical resource records deleted. (n=405)
   0   similar resource records  merged. (n=405)
   0 resource records edited:
   2 lines copied from temp_tail.html.
 405 resource records written.
dtcheck <yp_master.html
 428 blocks checked,    0 match failures.
ls -lg merged.html yp_master.html
-rw-r--r--  1 dwells   aipspgmr   105712 Feb 19 23:45 merged.html
-rw-r--r--  1 dwells   aipspgmr   105789 Feb 19 23:45 yp_master.html
dtsplit -v style=nrao  <yp_master.html
 405 resource records from input
  13 records >> temp_radio.html
  27 records >> temp_optical.html
   7 records >> temp_space.html
   3 records >> temp_solar.html
   2 records >> temp_survey.html
   5 records >> temp_weather.html
  26 records >> temp_center.html
   7 records >> temp_infosys.html
  13 records >> temp_dept.html
   2 records >> temp_society.html
   6 records >> temp_agency.html
  54 records >> temp_software.html
   1 records >> temp_document_tools.html
  20 records >> temp_pubs.html <------------STScI resources, not yet
  13 records >> temp_preprint.html                    classified 
   7 records >> temp_abstracts.html
   7 records >> temp_full_text.html
   7 records >> temp_bibliography.html
   3 records >> temp_library.html
   3 records >> temp_other_library.html
   6 records >> temp_people.html
   3 records >> temp_jobs.html
  10 records >> temp_meetings.html
  11 records >> temp_newsgroup.html
   4 records >> temp_astroweb.html
  16 records >> temp_other_astronomy.html
  22 records >> temp_pictures.html
  14 records >> temp_protocols.html
   4 records >> temp_misc.html
 102 records >> temp_net_res.html <-------STScI net_resources, not yet
                                                           classified 

Our combined resource list is much richer than the original lists.
The two of you are welcome to fetch whatever you want.
One of the yp files is a start toward emulating the STECF page.

Regards,
Don