Subject: FITS Browser/Extractor For MS-DOS

From: daves at regulus.demon.co.uk ("David M. Swain")
Date: Tue, 18 Jan 1994 13:32:04 +0000

Greetings

I am in the unfortunate position of having to run MS-DOS on my workstation
but I need to be able to manipulate FITS files ( not always TABLES ). Does
anyone know of a comprehensive ( or otherwise ) FITS file manipulation 
package for MS-DOS. I already have, and use, the FITS Table Browser, but
this only works for TABLES ( surprise, surprise ). 

Many thanks in advance
David
-- 
David M. Swain                      |   "Anything I do is my choice           "
45 Pheasant Way                     |   "But any effects from the things that "
Cirencester, Glos, GL7 1BJ          |   "I do are nothing to do with me.      "
England, +44 (0)285-655951          |
Internet: daves at regulus.demon.co.uk |

---

From: dwells at fits.CV.NRAO.EDU (Don Wells)
Date: Fri, 21 Jan 1994 16:20:08 GMT

In article <758899924snz at regulus.demon.co.uk>
    daves at regulus.demon.co.uk ("David M. Swain") writes:
 DMS> I.. run MS-DOS on my workstation.. need.. to manipulate FITS
 DMS> files ( not always TABLES ). Does anyone know of a.. FITS file
 DMS> manipulation package for MS-DOS.. 

This is a frequently-asked-question. The FITS community needs to have
a comprehensive answer to this question, but I am not aware of one at
the moment. The best I can do is to refer MS-DOS users to the
collection of messages in the archive directory

    ftp://fits.cv.nrao.edu/fits/os-support/dos/

The current contents of this directory are:

  -r--r--r--  1 dwells       2242 May  5  1993 ftb30b.mail
  -r--r--r--  1 dwells       3480 Apr  2  1993 imagine-32.news
  -rw-r--r--  1 dwells       1327 Nov  5 15:08 imdis79g.news
  -r--r--r--  1 dwells       4211 Dec 31  1992 imdisp-fits.news
  -r--r--r--  1 dwells       7399 Oct 15  1992 imdisp77.news
  -r--r--r--  1 dwells     342084 Oct 15  1992 imdisp77.zip
  -r--r--r--  1 dwells     131107 Oct 15  1992 imdisp78.exe
  -r--r--r--  1 dwells       5968 Oct 15  1992 imdisp78.news
  -r--r--r--  1 dwells       2827 Apr 29  1993 imdisp78b.news
  -r--r--r--  1 dwells      19075 Mar  4  1993 imdisp79.news
  -r--r--r--  1 dwells       1267 Dec  2  1992 ipsys.news
  -r--r--r--  2 dwells       6300 Jul 28  1991 listfits.c
  -rw-r--r--  1 dwells       3800 Nov  9 17:38 mips.news
  -r--r--r--  1 dwells       1735 Dec  3  1992 mira.news
  -r--r--r--  1 dwells       7010 Apr 28  1993 pcvista.news
  -r--r--r--  1 dwells        959 Mar 10  1993 s-and-t.news
  -rw-r--r--  1 dwells       3766 Jul  6  1993 vfits012.news
  -rw-r--r--  1 dwells        825 Aug  4 15:26 viewfits.news

I welcome reports of additional FITS-support packages or programs for
DOS/OS-2/Windows/etc. 

I wish that one or more people would construct reviews of the various
software solutions, and would either post them to sci.astro.fits or
else send them to me.  I would like to add such reviews to the
collection in this directory, and adaptations of them should be added
to the FITS FAQ posting.
--

  Donald C. Wells         Associate Scientist         dwells at nrao.edu
                    http://fits.cv.nrao.edu/~dwells
  National Radio Astronomy Observatory                +1-804-296-0277
  520 Edgemont Road,   Charlottesville, Virginia       22903-2475 USA

---

From: gwc at csd4.csd.uwm.edu (Greg F Walz Chojnacki)
Date: 18 Jan 1994 15:42:24 GMT

Damn!

Thats oak.oakland.edu. Directory is pub/msdos/astrnomy.

Greg
-- 
Only about 1 out of 8 federal dollars of social spending serves to lift poor
families above the poverty line. Only about one out of four federal benefit
dollars even flows to a program that uses financial need as a criterion for
elegibility.

---

From: steve at sarnia.demon.co.uk (Stephen)
Date: Mon, 24 Jan 1994 19:15:40 +0000

In article <CK4G2L.49q at cix.compulink.co.uk> mentha at cix.compulink.co.uk writes:

> Alternatively, does anyone know or is willing to make available some 
> software that'll turn a FITS image file into one more accessible on a PC 
> (e.g. BMP, TGA, PCX, GIF, TIF etc)?
> Best of all, maybe someone has written an Adobe Photoshop import filter?
> Simon Mentha
> (mentha at cix.compulink.co.uk)
> 
 I think that IMDISP79 can read FITS and write GIF,
 README file follows:
  -----------------------------cut here----------------------------------
                           ==================
                               IMDISP 7.9
                           ==================

     Version 7.9 of the IMDISP program has now been released.  IMDISP is an
interactive image processing program that runs on an IBM PC computer.  It was
written to be used with the Voyager and Magellan images which are available
on CD-ROM.  IMDISP has appeared on the GRIPS CDROM (version 4.4) and the
GRIPS 2 CDROM (version 5.6), and is currently distributed with the planetary
images CDROMs.

     IMDISP 7.9 is available via anonymous ftp at ames.arc.nasa.gov
[128.102.18.3] in a file called imdisp79.zip in the pub/SPACE/SOFTWARE
subdirectory.

     IMDISP79.ZIP consists of the following files:

                IMDISP.EXE   - IMDISP program version 7.9
                IMDISP.DOC   - User's Guide for IMDISP 7.9
                IMDISP.HLP   - IMDISP Help file
                PALETTES.ZIP - Collection of color palettes
                PAL.BAT      - Batch file to display each color palette
                CYCLE.BAT    - Batch file to color cycle each color palette
                COPIM.EXE    - Image copying program
                CONVERT.EXE  - Pixel conversion program

     The demo files have not changed but have been repackaged into two
files of more manageable sizes, IMDISPD1.ZIP and IMDISPD2.ZIP.  The demo
requires a minimum of a 800x600 graphics display, 3MB of memory, and 3MB of
hard disk space.

     Being one of the programmers for IMDISP, I would appreciate any
feedback on IMDISP, including any problems encountered and suggestions for
improvement.  The features of IMDISP are listed below.

        Ron Baalke
        Jet Propulsion Lab
        M/S 525-3684
        4800 Oak Grove Drive
        Pasadena, CA 91109
        Email: baalke at kelvin.jpl.nasa.gov

     IMDISP 7.9 features:
           * = updates since version 5.6
          ** = updates since version 7.4
         *** = updates since version 7.7
        o Basic Operations
             Image Display
             Image Sub Sampling
             Image Zooming
           **Image Rotation
           **Image Extraction
            *Image Buffering
            *Image Merging & Subtraction
            *Image Darkening & Brightening
             Image Flipping
             Histograms
             Image Browsing of CDROMs
             Text Display
             Profiling
        o Image Processing
             Contrast Enhancement
            *Smoothing
            *Edge Enhancement
            *Sharpening
            *Convolutions
            *3D Perspective
            *Smearing
            *Power Filtering
            *Image Masking
          ***High Pass Filtering
          ***Histogram Equalization
        o Color Palettes
             Load & Save
             Pseudo Coloring
            *Color Cycling
             Built-in Color Palettes
        o Graphics Support
             CGA
             EGA
             VGA
             Super VGA:
                ATI VGA Wonder
                Everex
                Orchid (ET3000 &  *ET4000 versions)
                Paradise
                PGA
               *Trident
        o File Formats Supported:
             Input:
                VICAR
                PDS
                FITS
                GIF (*GIF87a & **GIF89a)
                raw
             Output:
                PDS
               *GIF
             ***raw
        o Miscellaneous Features
            *Extended and Expanded Memory Support
            *Command Logging
            *Mouse Support
             Batch File Support

    ---------------------cut here------------------------------------------
stephen
-- 
  ______________________________________________
 [ Internet: email === steve at sarnia.demon.co.uk ]
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: mentha at cix.compulink.co.uk ("Simon Mentha")
Date: Tue, 25 Jan 1994 18:02:57 GMT

Gerald Edgar in <CK54M3.A70 at bcstec.ca.boeing.com> said:

> I'm currently writing up a simple filter program to convert FITS to
> BMP format. It currently runs (with a few bugs) under DOS. If I clean it
> up where should I send it so people can use it? 
> 
> P.S. I'm also writing up a version to use under windows - is there more 
> interest for that version?

This sounds very promising. Does your DOS program act like a "black box" 
i.e. you simply call it with the name of the input and output files? And 
are you thinking of making your Windows version callable as a DLL? This 
would help make it accessible to other Windows programs.

I (for one) would be happy to receive uuencoded mail when/if you are 
ready to try it out! Good luck & thanks for your response.

Simon Mentha
mentha at cix.compulink.co.uk

---

From: gwe3409 at bcstec.ca.boeing.com (Gerald Edgar)
Date: Mon, 24 Jan 1994 15:34:51 GMT

In article <CK4G2L.49q at cix.compulink.co.uk>,
>(mentha at cix.compulink.co.uk)

I'm curently writing up a simple filter program to convert FITS to
BMP format. It currently runs (with a few bugs) under DOS. If I clean it
up where should I send it so people can use it? 

Gerald Edgar
"Speaking for himself - for (and his kids) interest in the images"
gwe3409 at atc.boeing.com (work)
gwe3409 at halcyon.com (home)

---

From: gwc at csd4.csd.uwm.edu (Greg F Walz Chojnacki)
Date: 18 Jan 1994 16:13:01 GMT

>From article <758899924snz at regulus.demon.co.uk>, by daves at regulus.demon.co.uk ("David M. Swain"):
Status: O
X-VM-v5-Data: ([nil t nil nil nil nil nil nil nil]
	["1545" "mon" "" "" "19758899924" "" "" "article" "article" nil "53" "" nil nil nil "" nil nil (number " " mark "U    article                    53/1545  " thread-indent "\"\"\n") nil]
	nil)
> this only works for TABLES ( surprise, surprise ). 
Okay, since I screwed up 2X already, here are the results of an ARCHIE
search:

Host ftp.edvz.univie.ac.at

    Location: /pc/dos/graphics
           FILE -rw-r--r--     340909  May 31 1993  imdisp79.zip

Host freebsd.cdrom.com

    Location: /.2/simtel/msdos/graphics
           FILE -rw-r--r--     340909  May 31 1993  imdisp79.zip

Host ftp.wustl.edu

    Location: /systems/ibmpc/msdos/graphics
           FILE -r--r--r--     340909  May 30 1993  imdisp79.zip

Host ftp.technion.ac.il

    Location: /pub/unsupported/dos/simtel/graphics
           FILE -rwxr--r--     340909  Jun  1 00:00  imdisp79.zip

Host ftp.kuis.kyoto-u.ac.jp

    Location: /MSDOS/simtel20-archive/graphics
           FILE -rw-rw-r--     340909  May 31 1993  imdisp79.zip
    Location: /mirrors/simtel20.msdos/graphics
           FILE -rw-rw-r--     340909  May 31 1993  imdisp79.zip

Host ftp.iij.ad.jp

    Location: /.5/msdos/graphics
           FILE -r--r--r--     340909  May 30 1993  imdisp79.zip

Host cair.kaist.ac.kr

    Location: /systems/msdos/simtel/msdos/graphics
           FILE -r-xr-xr-x     336208  Jan 30 1993  imdisp79.zip

Host ftp.uu.net

    Location: /systems/ibmpc/msdos/simtel20/graphics
           FILE -rw-rw-r--     340909  May 31 1993  imdisp79.zip

Host ntu.ac.sg

    Location: /archive3/msdos/graphics
           FILE -r--r--r--     340909  May 31 1993  imdisp79.zip

---

From: mentha at cix.compulink.co.uk ("Simon Mentha")
Date: Mon, 24 Jan 1994 06:44:45 GMT

Simon Mentha

---

From: mentha at cix.compulink.co.uk ("Simon Mentha")
Date: Tue, 25 Jan 1994 18:03:01 GMT

In <759438940snz at sarnia.demon.co.uk>, steve at sarnia.demon.co.uk said:

> I think that IMDISP79 can read FITS and write GIF...

Thanks for reminding me about this - but looking at the elderly copy of 
IMDISP77A I have (which I appreciate may have changed in this area), you 
would need to display the image first and then specify which region of 
the image to save as a GIF. Since I've 110 images to look at, a "black 
box" converter program would suit me just fine!

(By the way, I also apologise to David Swain for hi-jacking his thread :-)

Simon Mentha

---

From: slegrand at netcom.com (Shawn P. Legrand)
Date: Wed, 2 Feb 1994 17:00:57 GMT

Simon Mentha (mentha at cix.compulink.co.uk) wrote:
: In article <758899924snz at regulus.demon.co.uk>
:     daves at regulus.demon.co.uk ("David M. Swain") writes:
:  DMS> I.. run MS-DOS on my workstation.. need.. to manipulate FITS
:  DMS> files ( not always TABLES ). Does anyone know of a.. FITS file
:  DMS> manipulation package for MS-DOS.. 

: Alternatively, does anyone know or is willing to make available some 
: software that'll turn a FITS image file into one more accessible on a PC 
: (e.g. BMP, TGA, PCX, GIF, TIF etc)?

: Best of all, maybe someone has written an Adobe Photoshop import filter?

: Simon Mentha
: (mentha at cix.compulink.co.uk)

There is a commercial product that can read and manipulate FITS
to other formats (such as BMP), plus it is a full desktop observatory -
it is called EP 2000 by Farpoint Software. It requires Windows 3.1 however.
Hope this helps.
-- 
*******************************************************************************
* Shawn P. Legrand                * The scientist does not study nature       *
* Sr. Systems Programmer          * because it is useful; he studies it       *
* ICW                             * because he delights in it, and he         *
* (619)-546-2457                  * delights in it because it is beautiful.   *
* INTERNET: slegrand at netcom.com   *                - Henri Poincare           *
* IBMMAIL:  USICWSPI              *                                           *
*******************************************************************************