Subject: FTP conversions to FITS

From: francois at SIMBAD.u-strasbg.fr
Date: Wed, 01 Feb 95 20:29:23 +0100

The CDS has recently incorporated a possibility of "on-the-fly"
transformation of tabular data into FITS ascii tables in its
anonymous FTP server (node  cdsarc.u-strasbg.fr)
This means that appending the suffix ".fit" or ".fits" to tables
(or .fiz for compressed-fits) generates the FITS equivalent of ascii
tables (when possible). The ftpd server was built from the WU-FTPD code.

This facility concerns over 1,000 tables for which we don't require
to build and maintain FITS versions. We hope that the FITS generated
is standard --- however we have conventions for UNIT which differ
from the proposed OGIP ones, and we do allow column names with
non-alphanumeric characters.

We would welcome any comment !
================================================================================

        _/_/_/_/_/_/ . . .             Centre de Donnees astronomiques de
      _/                               Strasbourg
     _/                                http://cdsweb.u-strasbg.fr/CDS.html
    _/        _/_/  _/_/_/             
   _/      _/      _/    _/            Francois Ochsenbein
    _/_/_/_/      _/    _/_/_/_/       Internet: francois at astro.u-strasbg.fr
         _/      _/    _/      _/         Phone: +33 88 35 84 11
          _/_/  _/_/_/        _/            Fax: +33 88 25 01 60
                             _/            Post: Observatoire Astronomique
                            _/                   11, rue de l'Universite
        . . . _/_/_/_/_/_/_/                     67000 STRASBOURG, France 

================================================================================

---

From: bschlesinger at nssdca.gsfc.nasa.gov (Barry M. Schlesinger)
Date: 6 Feb 1995 11:19 EDT

In article <9502011929.AA21512 at SIMBAD.u-strasbg.fr>, francois at SIMBAD.u-strasbg.fr writes...
>transformation of tabular data into FITS ascii tables .... 
>We hope that the FITS generated
	As I'm sure the OGIP people themselves would note, the 
adoption of a convention by OGIP does not make it part of the FITS 
standard.  The only likely requirements on units are those in the 
current draft put out by the NOST Technical Panel.
	However, it will be best for all concerned if those producing 
data in a particular discipline, such as high energy astrophysics, can 
agree on a set of conventions to be used in that area.  OGIP is making 
an important contribution to this end by developing its detailed set of 
conventions.  But these conventions should not be treated as a 
set only for OGIP, with other conventions to be developed elsewhere.  
The idea is for the OGIP drafts to serve as the basis for development 
of universal conventions to be used in high energy astrophysics and 
perhaps elsewhere.  In this context, those who see problems with the 
OGIP conventions in a particular area or whose local preference in 
a particular area is different should bring the specific issues here for 
public discussion, to allow movement towards a consensus convention.

				Barry Schlesinger
				NSSDC/NOST FITS Support Office