Subject: Re: MJD - not acceptable according to IAU (?)

From: sla at umbra.ucolick.org (Steve Allen)
Date: 1 Jul 1996 19:27:34 GMT

In article <31D80C21.7662 at ast.cam.ac.uk>, Guy Rixon  <gtr at ast.cam.ac.uk> wrote:
[about MJD-OBS]
>            In fact it's  one of the few keywords that's unambiguous already
>without  needing an offical definition.

MJD is ambiguous by about a minute depending on whether you mean
ET, UT, TAI, or some other timescale.
--
Steve Allen          UCO/Lick Observatory       Santa Cruz, CA 95064
sla at ucolick.org      Voice: +1 408 459 3046     FAX: +1 408 454 9863
WWW: http://www.ucolick.org/~sla                PGP public keys:  see WWW

---

From: Guy Rixon <gtr at ast.cam.ac.uk>
Date: Mon, 01 Jul 1996 18:34:25 +0100

Pierre Maxted wrote:
> 
> In article <4qroqt$7s4 at darkstar.UCSC.EDU>, Steve
> Allen <sla at umbra.ucolick.org> wrote:
> >Take note, however, of the WCS draft paper at
> >http://fits.cv.nrao.edu/documents/wcs/wcs.html
> >which proposes to standardize the usage of MJD-OBS.  This will work
> : : :
>  ... which reminds me that at the last IAU general meeting there was some
> discussion of abondoning MJD since it was ambiguous/redundant. Am I
> correct? Is it feasible to drop MJD from the FITS standard?

You can't drop something from the standard that isn't in yet.  Even if
MJD-OBS never becomes a mandatory part of the WCS extension to the FITS
standard, it's still valid as a general-purpose keyword  for observatories
to supply.  In fact it's  one of the few keywords that's unambiguous already
without  needing an offical definition.

-- 
Guy Rixon,				gtr at ast.cam.ac.uk 
Software Engineering Group,		Tel: +44-1223-374000
Royal Greenwich Observatory 		Fax: +44-1223-374700

---

From: Mike Corcoran <corcoran at barnegat.gsfc.nasa.gov>
Date: Tue, 02 Jul 1996 10:12:43 -0400

> ET, UT, TAI, or some other timescale.

also, MJD-OBS, defined as the "date of the observation" is ambiguous by definition -
is this the start of the observation, the midpoint, etc?  This difference is
significant to the X-ray community, where a given image is generally composed of
individual segments obtained over an interval of many days.

Mike
-- 

***********************************************************
Dr. Michael F. Corcoran
High Energy Astrophysics Science Archive Research Center
Goddard Space Flight Center
Greenbelt, MD 20771
corcoran at barnegat.gsfc.nasa.gov
LHEAVX::CORCORAN
http://lheawww.gsfc.nasa.gov/users/corcoran/bio.html
***********************************************************

---

From: pausch at electra.saaf.se (Paul Schlyter)
Date: 4 Jul 1996 07:22:48 +0200

In article <4r98r6$e6r at darkstar.ucsc.edu>,
 
> ET, UT, TAI, or some other timescale.
 
I've never seen JD or MJD used with TAI as the fundamental time scale.
One implicitly assumes UT as the basic time scale, which still leads
to a small ambiguity of course since "UT" can be either of UTC, UT0,
UT1 or UT2.....
 
Astronomers sometimes use JD based on ET (nowadays TDT) -- to show
that, they talk about "JED" in such cases.
 
---------------------------------------------------------------------------
 
There are more serious ambuiguities involved here though.  MJD is
often used, by various people, as any day count, starting at any day
they feel is suitable.  And even JD is subject to this: the NORAD
people, who keep track of all our artificial satellites, have their
own definition of JD.  Today's date is 1996-07-03, let's assume it's
15:00 UT.  This will become:
 
   Astronomer's JD:  2450268.125
   NORAD "JD":           185.625
 
The NORAD "JD" is simply a count of the number of days into the year, and
it's reset to 1 at the beginning of each new year.
 
I once complained to T.S. Kelso (he's the one who use to post
satellite orbital elements in sci.space.news) about this usage of
"JD".  He responded that he understood my point of view, but that
this usage now is so widespread within NORAD that there's no hope in
changing it.
 
-- 
----------------------------------------------------------------
Paul Schlyter,  Swedish Amateur Astronomer's Society (SAAF)
Grev Turegatan 40,  S-114 38 Stockholm,  SWEDEN
e-mail:  pausch at saaf.se        psr at home.ausys.se

---

From: pausch at electra.saaf.se (Paul Schlyter)
Date: 4 Jul 1996 07:23:42 +0200

In article <31D92E5B.41C6 at barnegat.gsfc.nasa.gov>,
Mike Corcoran  <corcoran at barnegat.gsfc.nasa.gov> wrote:
 
> also, MJD-OBS, defined as the "date of the observation" is ambiguous by
> definition - is this the start of the observation, the midpoint, etc?
> This difference is significant to the X-ray community, where a given
> image is generally composed of individual segments obtained over an
> interval of many days.
 
And this ambiguity has nothing to do with MJD -- it'll still be there
if you use JD, ordinary calendar dates, number of seconds since
1970-01-01, or whatever.
 
If the duration of the observation becomes significant, information
about this must of course be included.  The appropriate action is
then to give "start of observation" and "end of observation" or
"duration of observation".  If the observation is stopped and
restarted repeatedly, this too may be insufficient - in such
cases one simply must supply enough details about the observation,
for instance time of each start and stop.

---

From: Lucio Chiappetti <lucio at ifctr.mi.cnr.it>
Date: Fri, 5 Jul 1996 14:46:31 +0200 (MET DST)

On 4 Jul 1996, Paul Schlyter wrote:

> own definition of JD. 
  [...]
> it's reset to 1 at the beginning of each new year.

  I've often seen on various (non-astronomical) newsgroups people
  talking of "Julian Day number" as the number of days in the year.
  Since I think this is inexact and to be DEPRECATED, I usually respond
  to such pointing telling them that this is NOT JD (the 244.... thing)
  but should be called something else.

  It is true also that there are (or were) places using "their own"
  "M"JD (as days elapsed since a given date, not just subracting
  2400000.5), for instance I recall that some 10-12 years ago at the
  ESOC (European Space Operation Centre) they used an "MJD" which was
  in days elapsed since 0 UT of 1 Jan 1950   ... I recall a telex from
  a guy in Leicester telling them this was wrong, that they should use
  the (formerly IAU supported) MJD which "was used by astronomers
  throughout the civilised world and also in Leicester".
  [From this some humorous fellow scribbled below it "from which one
  infer Leicester is not part of the civilised world" :-) ]

---

From: bschlesinger at nssdca.gsfc.nasa.gov (Barry M. Schlesinger)
Date: 5 Jul 1996 09:25 EDT

In article <4rfkf8$idg at electra.saaf.se>, pausch at electra.saaf.se (Paul Schlyter) writes...
>the NORAD

I've seen it elsewhere.  The misuse of the term "Julian Day" to 
represent day-of-year has not been at all uncommon in the area of 
tracking satellites and processing the data. 

				Barry Schlesinger

---

From: Peter Bunclark <psb at ast.cam.ac.uk>
Date: Fri, 05 Jul 1996 15:07:48 +0100

> tracking satellites and processing the data.

Did these guys write the Ariane-5 navigation software?

No matter how much you wish for it, some old FITS readers cannot be updated -
don't have source, don't have library, can't remember how to use a line editor...
Software which *is* maintainable is not a problem.
	The ISO-DATE idea seems great to me, perhaps UTC-DATE being a bit more
definite.  I still think it's best to drop DATE-OBS;  then old software can't 
possibly misinterpret it, but old software is much more likely to handle its
absence gracefully.
	As for MJD-OBS, it serves a different purpose;  you don't read it yourself, you let
your period-finding software loose on it.  And as has been pointed out,
the definition is watertight,  if you can't understand the 0.5 day thing then 
you're not clever enough to do astrophysics.

I want to do this:
1) leave MJD-OBS alone, but recommend it is UT of start of observation; comments
         to clarify;
2) Remove DATE-OBS from FITS writers, certainly after 2000.
3) Adopt UTC-DATE in ISO format, allowing full time-resolution - ie new software
    has to be prepared to parse any allowable case.  A reader encountering 
    DATE-OBS and UTC-DATE takes the newer one as true, or, does a consistency
    check between the two.
	UTC-DATE will refer to the start of observation unless comments or other
     descriptors indicate otherwise.

Pete.

---

From: pausch at electra.saaf.se (Paul Schlyter)
Date: 7 Jul 1996 11:17:40 +0200

In article <Pine.3.89.9607051404.S15993-0100000 at poseidon.ifctr.mi.cnr.it>,
 
>   but should be called something else.
 
This can be expected among non-specialists.  But I was quite
disappointed to find out that this erroneous use of JD was common in
a space agency!!!

This discussion has become off-topic for sci.astri.fits though --
followups to sci.astro