Subject: schedules and ephemeris in FITS

From: "Eric C. Olson" <[email-masked]>
Date: Tue, 15 Mar 94 14:05 EST

Hi,

I'm interested in improving communications between EUVE Guest
Investigators and CEA on spacecraft scheduling issues.  In particular,
I'm interested in finding out about FITS binary table formats that
have been defined (or used) to transmit data about ephemeris.  Also,
has anyone worked on representing scheduling information -- ie, when a
target is visible, when star trackers are operable, etc.

For the ephemeris, I'm looking for a relative simple file containing
say 3 columns: time, ra, dec (including appropriate header information
about coordinate systems, units, etc).  It would be nice to have a 4th
column with the radial distance.  For example, in scheduling Moon
observations, EUVE must account for the relative position of the Moon
to the spacecraft.  Has anybody come across this type of FITS table?

I think that the scheduling information is more complex.  The basic
information in our scheduling system is "run-length encode" --
intervals of time are suitable (or not).  In practice, however, these
time intervals are actually all the same size.  Additionally, the
suitability of the observation during the time interval has a metric
that runs from 0 (not suitable) to 1 (most suitable).  I'm not sure
how common this system is for other spacecraft scheduling systems.

For all the suitable time intervals, we would like to maintain a list
of all the roll angles that are valid to use for the duration of the
time interval.  Additionally, for all non-suitable time intervals, we
would like to know which pointing constraint was violated.

I'd appreciate any information on either of these issues, or other
systems that are related to these problems.

Thanks in advance,
Eric

---

From: [email-masked] (Mike Corcoran)
Date: Tue, 15 Mar 94 17:08 EST

> From [email-masked] Tue Mar 15 14:11:05 1994
> Date: Tue, 15 Mar 94 14:06 EST
> Sender: [email-masked] (listserv server)
> Reply-To: [email-masked]
> Originator: [email-masked]
> Sender: [email-masked]
> From: "Eric C. Olson" <[email-masked]>
> To: [email-masked]
> Subject: schedules and ephemeris in FITS
> X-Listprocessor-Version: 6.0 -- ListProcessor by Anastasios Kotsikonas
> Content-Length: 1697
> 
> Hi,
> 

Haven't really thought to much about a FITS file for scheduling info,
but ROSAT includes most of the emphemeris info you want in a trend data
file.  The format of the file is given in the following header (the
meaning of the columns are explained in the comment fields). (I've only
included the fields which seem like they might be relevant to you).

I don't know if you are aware but the Office of Guest Investigator
Programs at GSFC has a working group to deal with format issues for
FITS files used for high energy data.  (you probably have seen our
posts here from time to time).  Some of the prior recommendations of
this working group can be downloaded anonyomously from
legacy.gsfc.nasa.gov in the directory documents/fits/ofwg_recomm.

Hope this is of some use.

Mike Corcoran
HEASARC
Goddard Space Flight Center
Greenbelt, MD 20771
[email-masked]
HEASRC::CORCORAN

XTENSION= 'BINTABLE'           /
BITPIX  =                    8 /
NAXIS   =                    2 /Binary table
NAXIS1  =                  126 /Number of bytes per row
NAXIS2  =                 1340 /Number of rows
PCOUNT  =                    0 /Random parameter count
GCOUNT  =                    1 /Group count
TFIELDS =                   30 /Number of columns
EXTNAME = 'Trend   '           /Contains trend data on 60 sec sample interval
TFORM1  = '1D      '           /Real*8 (double precision)
TTYPE1  = 'TIME    '           /Corrected spacecraft time of measurement
TUNIT1  = 's       '           /Units of column 1
TFORM2  = '1D      '           /Real*8 (double precision)
TTYPE2  = 'second  '           /UT sec since beginning of DATE-OBS
TUNIT2  = 's       '           /Units of column 2
TFORM3  = '1D      '           /Real*8 (double precision)
TTYPE3  = 'MJD     '           /Modified Julian Date (JD-2400000.5)
TUNIT3  = 'd       '           /Units of column 3
TFORM4  = '1E      '           /Real*4 (floating point)
TTYPE4  = 'RASAT   '           /Satellite RA
TUNIT4  = 'deg     '           /Units of column 4
TFORM5  = '1E      '           /Real*4 (floating point)
TTYPE5  = 'DECSAT  '           /Satellite Dec
TUNIT5  = 'deg     '           /Units of column 5
TFORM6  = '1E      '           /Real*4 (floating point)
TTYPE6  = 'ALT_SAT '           /Satellite Altitude
TUNIT6  = 'km      '           /Units of column 6
TFORM7  = '1E      '           /Real*4 (floating point)
TTYPE7  = 'RASUN   '           /RA of Sun
TUNIT7  = 'deg     '           /Units of column 9
TFORM8  = '1E      '           /Real*4 (floating point)
TTYPE8  = 'DECSUN  '           /Dec of Sun
TUNIT8  = 'deg     '           /Units of column 10
TFORM9  = '1E      '           /Real*4 (floating point)
TTYPE9  = 'RAMOON  '           /RA of Moon
TUNIT9  = 'deg     '           /Units of column 11
TFORM10 = '1E      '           /Real*4 (floating point)
TTYPE10 = 'DECMOON '           /Dec of Moon
TUNIT10 = 'deg     '           /Units of column 12
TFORM11 = '1E      '           /Real*4 (floating point)
TTYPE11 = 'RAB     '           /RA of local B-field
TUNIT11 = 'deg     '           /Units of column 13
TFORM12 = '1E      '           /Real*4 (floating point)
TTYPE12 = 'DECB    '           /Dec of local B-field
TUNIT12 = 'deg     '           /Units of column 14
TFORM13 = '1E      '           /Real*4 (floating point)
TTYPE13 = 'LVAL    '           /MacIlwain L parameter
TUNIT13 = '        '           /Units of column 15
TFORM14 = '1E      '           /Real*4 (floating point)
TTYPE14 = 'ZENANG  '           /Orbit position-look direction (zenith) angle
TUNIT14 = 'deg     '           /Units of column 16
TFORM15 = '1E      '           /Real*4 (floating point)
TTYPE15 = 'SESANG  '           /Sun-Earth-Satellite angle
TUNIT15 = 'deg     '           /Units of column 17
TFORM16 = '1E      '           /Real*4 (floating point)
TTYPE16 = 'VELANG  '           /Velocity vector-look direction (ram) angle
TUNIT16 = 'deg     '           /Units of column 18
TFORM17 = '1E      '           /Real*4 (floating point)
TTYPE17 = 'MAGANG  '           /Magnetic field-look direction angle
TUNIT17 = 'deg     '           /Units of column 19
TFORM18 = '1E      '           /Real*4 (floating point)
TTYPE18 = 'SUNLOOK '           /Look direction-Sun angle
TUNIT18 = 'deg     '           /Units of column 20
TFORM19 = '1E      '           /Real*4 (floating point)
TTYPE19 = 'MOONLOOK'           /Look direction-Moon angle
TUNIT19 = 'deg     '           /Units of column 21
END