Subject: Testing of BINTABLE and IMAGE extensions

From: [email-masked]
Date: Tue, 19 Oct 93 13:33:46 +0100

Dear IAU-FWG members,
 To encourage you to participate in the test/verification
of data exchange using the BINTABLE and IMAGE extensions,
I have placed some test files on our anonymous ftp account
here in ESO (Thank you to those of you who already have
volunteered).
 The files can be obtained on the anonymous ftp account on
'ftphost.hq.eso.org' with IP 134.171.8.4. You should go to
the subdirectory incoming/fitstest which you can do a 'ls -l'
of. There is also a README file as follows:

File         Remarks
---------------------------------------------------------------------
tst0001.mt   Simple 8-bit integer ramp
tst0002.mt   Simple 16-bit integer file with 3 axes 
tst0003.mt   Simple 32-bit integer file
tst0004.mt   Simple 32-bit integer file with scaling
tst0005.mt   Simple 32-bit IEEE Floating Point file
tst0006.mt   Simple 64-bit IEEE Floating Point file
tst0007.mt   Test file with 32-bit IEEE Fp special values
tst0008.mt   Test file with 64-bit IEEE Fp special values
tst0009.mt   ASCII Table extension  + IMAGE extension
tst0010.mt   BINary Table extension + IMAGE extension
tst0011.mt   IMAGE extension + ASCII Table extension
tst0012.mt   Simple 32-bit IEEE + BINTABLE + UNKNOWN + IMAGE + TABLE
tst0013.mt   Image file with ESO HIERARCH keywords
tst0014.mt   Sample of ESO-MIDAS BINTABLE extension

You are welcome to try all the files (tst0007 and tst0008 are
a lot of fun!) but for verification you should read the files
tst0009-tst0012 and tst0014. In a few days I will post the
values of some explicit table/image elements so that we can see
if we agree on the values. Should I have made some mistake
in the file headers please e-mail me as soon as possible.

It would be very good if some of you would also place you
BINTABLE/IMAGE extension files on anonymous ftp accounts
and announce them free for tests!

Best regards,
Preben

---

From: [email-masked] (William Pence)
Date: Mon, 25 Oct 93 17:22:43 EDT

Dear IAU-FWG members,

I've looked at the new FITS test files produced by Preben Grosbol
(with the revised BINTABLE extensions) and have placed new ASCII listings
of the 2 affected files (tst0010 and tst0012) in my anonymous ftp directory
on tetra.gsfc.nasa.gov in the /pub/test/ subdirectory.  The number of elements
in each variable length row now is in agreement with the maximumn number
given in the TFORM keyword.

Regarding the wording of the Append. B on the P-format, I'd suggest that
the MAXLEN value given in the TFORM keyword should be the maximumn number
of elements in each row that FITS readers are expected to be able to read.
If there are more pixel elements than this in a given row, then readers
may ignore the additional elements.  But the additional elements are still
valid data for FITS readers that are capable of reading them.

Regards,
Bill Pence