Subject: Re: FITS image file

From: [email-masked] (GUNNAR RADONS)
Date: Tue, 22 Oct 91 18:18:16 CET

In article <[email-masked]>
[email-masked] (Moon Gi Kang) writes:

>Does somebody outthere has any information about
>the way to convert FITS image files to another
>type format of images?...
>
Rehi,
the easiest way to do is: Display the image, grab it with the grabber of your
favourite graphics editor and then load that grabbed file and save it in any
format that you like.
If you like to do it rhe hard way, then ftp (if you have access to it) to the
anonymous account at the nrao (fits.cx.nrao.edu or 191.33.115.8), go to the
fitsio subdirectory and grab the fitsio package (it's written in FORTRAN).
Then you may write your own FITS to something conversion utility.
Bye, Gunnar

---

From: [email-masked] (Edouard Boily)
Date: 22 Oct 91 23:23:18 GMT

In article <[email-masked]> [email-masked] (Moon Gi Kang) writes:
>Hi,
>type format of images?
>(I got some astronomical images and 
>want to do image processing, but
>I have never used FITS)
>Any other format(gif, raster, rawbinary, FBM TIFF and so on)
>will be ok with me.
>
>Thank you in advance for your rapid response.
>
>-moon-

	I recommend pbmplus.  It can convert from a great deal of
formats, including FITS to the same deal of formats (including the one
you want).  pbmplus is free (PD) and available at a lot of anonymous
ftp sites.  The latest version is dated Oct05.

 - Edouard
.---------------------------------------------------------.
|                   [email-masked]                   |
|---------------------------------------------------------|
| Edouard Boily  | Projects: AmiGraph, AmigIRAF           |
| Physic's Dept. | Interests: Astronomy, Comp. Sciences   |
| Laval Univ.    | Work: On my Ph. D.            _ //     |
| Quebec, CANADA | Citation: Not yet!            \X/      |
`---------------------------------------------------------'

---

From: [email-masked] (Archie Warnock)
Date: 24 Oct 91 16:55:00 GMT

In article <[email-masked]>, [email-masked] (Edouard Boily) writes...
>formats, including FITS to the same deal of formats (including the one

Last version I saw of pbmplus only handled FITS format for 8-bit images. 
IMDISP will also handle 16-bit integer images, but not floating point 
(yet).

----------------------------------------------------------------------------
-- Archie Warnock                     Internet:  [email-masked]
-- Hughes STX                         SPAN:      NSSDC::WARNOCK
-- NASA/GSFC                          "Unix - JCL for the 90s"

---

From: [email-masked] (Al Wootten)
Date: Wed, 23 Oct 1991 15:03:44 GMT

>   the way to convert FITS image files to another
If you are using a PC, imdisp77 from ames.arc.nasa.gov will accept/write
FITS format (NAXIS=2 and 16 bits) and gif or vicar formats.  It
will allow you to do a lot of image processing, too.

--
+--------------------------------------------__---------+
| Alwyn  Wootten			     \/		|
| National Radio Astronomy Observatory        ^         |
| 520 Edgemont Road, Charlottesville, VA 22903-2475, USA|
|                                                       |
| [email-masked]             [email-masked]    |
| 6654::awootten (SPAN) Let's build The Millimeter Array|
| (804)-296-0329               {>    {>    {>    {>     |
+------------------------------^-----^-----^-----^------+

---

From: [email-masked] (Moon Gi Kang)
Date: Fri, 25 Oct 1991 02:33:30 GMT

>IMDISP will also handle 16-bit integer images, but not floating point 

YES, 
I tried to use pbmplus to convert FITS to another format,
but unfortunately, my data is 16-bit integer format. 
And one more unfortunate thing is, my machine is not IBMpc
but Sun work station(spark1). I guess IMDISP is for DOS.

Is there any powerful package to convert my data to another format?

-moon-

PS: So, I made my own program to remove the head of FITS
and then converting it to 8bit binary data in IDL.

---

From: [email-masked] (Archie Warnock)
Date: 25 Oct 91 14:25:00 GMT

In article <[email-masked]>, [email-masked] (Moon Gi Kang) writes...
>but Sun work station(spark1). I guess IMDISP is for DOS.

Yep - sure is, and pretty hardware specific, at that (for those of you 
thinking you might convert it to other platforms).

>and then converting it to 8bit binary data in IDL.

You seem to have answered your own question - that would have been my 
answer, too.  There are libraries of IDL procedures for reading/writing 
FITS, though, so the first step wasn't really necessary.

---

From: [email-masked] (Ray Sterner)
Date: 25 Oct 91 16:52:02 GMT

. . .

>and then converting it to 8bit binary data in IDL.

  Users of the computer language IDL may be interested in a library
  of IDL routines that is available by anonymous ftp.  It has about
  400 routines and includes a set that deal with FITS files.  They
  allow simple FITS files to be created and read.  There are also
  several other routines of astronomical interest.

  Accessing the ftp site
  ----------------------
  ftp 128.244.147.14 (fermi.jhuapl.edu)
    For Name type: anonymous
    For Password type anything.
    Change directory by typing: cd idl-pvwave/jhuapl
    To get a file type: get filename
    When finished type: bye.

    Two files of interest are:
    README = describes what is in the ftp site and how to get it.
    cat.one = one line descriptions of the IDL routines by category.

  Those of you that don't know about the IDL computer language may
  want to check it out.  Its a high level, interpreted language that
  is very strong on graphics and imaging.  It has many efficient array
  operations built-in, so just because it is an interpreter doesn't
  mean its slow.  It runs on most workstations and will soon be on
  DOS machines and Macs.  I have run an evaluation copy on a Compaq
  386/25Mhz machine and was very happy with it.  If you don't know about
  it its worth checking.  You can get a copy over the net to try for
  30 days (I don't know what you do for documention).

  Ray Sterner                     [email-masked] 
  Johns Hopkins University        North latitude 39.16 degrees.
  Applied Physics Laboratory      West longitude 76.90 degrees.
  Laurel, MD 20723-6099

---

From: [email-masked] (Ron Watkins)
Date: 27 Oct 91 14:31:53 GMT

Well, This may not be the easy way out, but you could put IRAF on your SUN
host. We use it all the time for image processing and it has image display
tools and powerful graphics, fitting, and other I/P functions all astronom-
ically related. It will read fits into internal IMAGE format using 'rfits'
and 'wfits' and can display with a variety of grey-scales and pseudo-colors.
Contact: [email-masked] OR [email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Ron Watkins			[email-masked]
931 Gould-Simpson		(602) 621-8606
University of Arizona
Tucson, AZ. 85712