Subject: Re: No ST-6 FITS images ?

From: newberry at newton.as.arizona.edu (Mike Newberry)
Date: 1 Apr 1994 22:49:01 GMT

In article <94088.142150K3032E0 at ALIJKU11.BITNET> Herbert Raab <K3032E0 at ALIJKU11.BITNET> writes:
>I once read a posting saying that FITS images written by the software of
>the ST-6 CCD camera do not fullfill the FITS standard. Anyway, I can not
>remember the reason (if one was given at all).
>
>What's wrong with the files written by the ST-6 software ?
>

They have 16 bit unsigned pixels.  So when you import them, the FITS
reader thinks they are 16 bit signed integers.  It makes pixel values
over 32767 wrap around to 65536 lower and you see black holes in the`
middle of starts and other bright peaky objects.  The spectrasource
cameras do the same thing.  More people who manufacture CCD cameras nee
to read the FITS spec.

Mike Newberry

---

From: rlm at astro.physics.uiowa.edu (Robert Mutel)
Date: Sat, 2 Apr 1994 15:27:34 GMT

Regarding 16 bit unsigned integers in ST6/SpectraSource FITS images:

1. In both the ST-6 and SpectraSource software, one has the ability to subtract 32767 from all pixels
before writing the FITS image. This 'fixes' the wrap around problem for pixels with counts >32767, although
the pixels then have a range from -32767 tro + 32767. 

2. An alternate approach for the ST-6 is to use Compuscope's Personal Observatory software to control 
the ST-6. This is *much* better than SBIG's software in any case, and does the 32767 subtraction
automatically. Unfortunately it doesn't support the 'track and accumulate' feature, but it does have filter
wheel control built in.

3.  We have written our own camera control software for the HPC-1 which complies with the [current] FITS standard. It is part of a complete telescope/camera robotic system and is written in C for a Unix/Motif
platform running on a PC with an ISA bus.  Anyone interested in more details can contact me directly.

Robert Mutel
Department of Physics and Astronomy
University of Iowa
Iowa City IA 52242

Telephone: 319-335-1950      FAX: 319-335-1753
Email: rlm at astro.physics.uiowa.edu  (internet) 
       iowa::rlm (span)

---

From: newberry at astro.as.arizona.edu (Mike Newberry)
Date: 8 Apr 1994 18:27:10 GMT

>2. An alternate approach for the ST-6 is to use Compuscope's Personal Observatory software to control 

There's another away to do this:  MIRA automatically knows that Spectrsource
and SBIG images are 16 bit unsigned and it imports them correctly.  It also
allows you to specify that any incoming FITS file is actually unsigned (invalid
FITS, actually] and import it correctly.

Mike Newberry

---

From: gsmoot at pts.mot.com (George Smoot X2612 P7989)
Date: Sun, 10 Apr 1994 16:50:47 GMT

Herbert Raab (K3032E0 at ALIJKU11.BITNET) wrote:
: I once read a posting saying that FITS images written by the software of
: the ST-6 CCD camera do not fullfill the FITS standard. Anyway, I can not
: remember the reason (if one was given at all).

: What's wrong with the files written by the ST-6 software ?

:   Herbert

While the ST-6 software dumps it's FITS files in 16-bit unsigned integers
which is not a valid FITS format, the SBIG people do include BZERO and
BSCALE values in the header which should allow (if I read the spec correctly)
these images to be interpreted correctly.  I have no problem reading ST-6
images into SAOIMAGE or IRAF.

George Smoot
(Lake Worth, FL)

---

From: beaucham at leo.phy.ulaval.ca (Dominique Beauchamp)
Date: Wed, 13 Apr 1994 13:26:14 GMT

>images into SAOIMAGE or IRAF.
Curiously, mine appear flipped upside down...

Dominique Beauchamp

-- 
Dominique Beauchamp	  | Developer of ViewFITS, a FITS  
Labo. d'astrophysique,    | viewer for OS/2 2.1
U. Laval, Ste-Foy, G1K7P4 | Next release: spring 1994 
beaucham at phy.ulaval.ca    | ftp.cdrom.com

---

From: eychaner at SUNCUB.BBSO.CALTECH.EDU ("Channel Energy")
Date: 13 Apr 1994 18:33:59 GMT

beaucham at leo.phy.ulaval.ca (Dominique Beauchamp) writes:
>gsmoot at pts.mot.com (George Smoot X2612 P7989) writes:

	So do the Big Bear Solar Observatory FITS files (available by
anonymous FTP to suncub.bbso.caltech.edu), on many FITS viewers.  We
write our data in the order it comes off the chip (or digitizer); i.e.
left to right and top to bottom (the first value is in the upper left),
to avoid having to invert the array.  "Top" and "left" are somewhat
arbitrary with respect to the sun as well, depending on the optical
configuration.  (It's all explained in the 000README.NOW file on our
image archive.)
	Many FITS viewers display left to right and bottom to top (the
first value is in the lower left).  Is this behaviour specified by the
standard (I couldn't find it, but I have an older copy)?
	SAOimage accepts a command line argument specifying where the
first pixel goes (and thus the axis directions).

-G.

Glenn Eychaner, C Programmer & VMS Manager, Big Bear Solar Obs., Caltech
eychaner at suncub.bbso.caltech.edu  (909)866-5791  40386 North Shore Lane
SUNCUB::EYCHANER, 5554::EYCHANER  (818)395-4014  Big Bear City, CA 92314