Subject: fitsio package - on VxWorks

From: Maren Purves <m.purves at jach.hawaii.edu>
Date: Wed, 15 Apr 1998 11:01:36 -1000

Hi all,

I'm trying to run fitsio on a VME crate running VxWorks. The test
program runs fine and with the expected (hoped for) output.

Now comes the part where it doesn't anymore:
I can create a file, write some header information to it
and then the data array. When adding more header information
at some point it starts corrupting my data array. I have traced
it down to that the data array gets corrupted in the routine
that writes it. Adding more header lines neither moves nor
increases the size of the corrupted area.

Has anybody seen a similar problem?
Any idea what I might be doing wrong?

Thanks in advance,

Maren Purves,
UKIRT, Hilo, HI

---

From: pence at tetra.gsfc.nasa.gov (William Pence)
Date: Wed, 15 Apr 1998 17:27:13 -0400

Maren,

Send me more details (offline from this group) about which version of
fitsio you are using and what fitsio subroutines are being called.

-Bill Pence