Subject: Raw data to FITS

From: Bernd Nies <bernd.nies at astroinfo.org>
Date: Wed, 26 Aug 1998 20:42:56 +0200

Hi,

Is there somewhere a little command line program
that converts an input file with a raw binary data stream 
into FITS format?

I know the 'convert' program from ImageMagick but this
does only convert 8 bit grayscale or 3x8 bit RGB files.

Input file description:

Simple uncompressed binary data stream from a CCD.
pixel organization on CCD:
	,----------,
	| yz012345 |
	| qrstuvwx |
	| ijklmnop |
	| abcdefgh |
	'----------'

and written into raw data file:
,----------------------------------,
| abcdefghijklmnopqrstuvwxyz012345 |
'----------------------------------'

one pixel data: 
- 16 bit (or less)
  unsigned short Intel (little endian)
  or Motorola (big endian) syntax.

The program should run under Linux.

Does someone already know a little program that
does this job? If not I would write a Perl script
for this.

Regards,

Bernd
       _
_____ | | ___________________________________________
\__  \| | Bernd Nies         bernd.nies at astroinfo.org
 / __ \\| Chindismuelistr.6  http://www.astroinfo.org
(____  /_ CH-8626 Ottikon    
     \/\/

---

From: richmond at a188-l009.rit.edu (Stupendous Man)
Date: 27 Aug 98 17:41:31 GMT

> The program should run under Linux.

  You might try grabbing the "XVista" suite from my WWW pages:

     http://a188-L009.rit.edu/tass/software/xvista/index.html

It builds under Linux, and includes a program called "convert"
which probably does the task you request.  

  Let me know if it doesn't quite work properly, and I'll try
to help.

-- 
-----                                      
Michael Richmond                   "This is the heart that broke my finger."
mwrsps at rit.edu                     http://a188-L009.rit.edu/richmond/