Subject: FITS and Java

From: "Arno M. Plug" <aplug at iso.vilspa.esa.es>
Date: Wed, 14 Apr 1999 10:57:04 +0200

Hi,

I am looking for any information on any Java packages/implementations
that provide ways of browsing and visualizing scientific data in FITS
format. In case you know any or about any related information, please
let me know.

Thanks and regards,

Arno.

---

From: Tom McGlynn <tam at silk.gsfc.nasa.gov>
Date: Thu, 15 Apr 1999 10:12:47 -0400

Dear Arno,

There are a systems available for handling FITS
in Java.  You may want to look at the Java FITS
library that I've written to access image and binary
table FITS data. [Try the links
in http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/fits_libraries.html ]

There are higher level visualization packages avaiable.
The NCSA's Horizon system does 2-D visualization of FITS images
[ http://imagelib.ncsa.uiuc.edu/Horizon ]
There's a package WebWinds developed at JPL which handles FITS data
and includes visualization tools.
[ http://webwinds.jpl.nasa.gov/ ]

There are several other systems, e.g., SkyView, in which a visualizer for
FITS images is embedded and where one might extract the relevant code.
[ Try the Java interface under http://skyview.gsfc.nasa.gov ]

Hope these starting points help.

	Regards,
	Tom McGlynn
	NASA/GSFC