Subject: Re: HDF scientific data, SD interface

From: [email-masked] (Gilles Ratel (8720))
Date: Sun, 25 Jun 1995 02:52:53 GMT

Doug Ilg writes:

> Also, I would urge you to use the newer "SD" interface to HDF SDSs.  
> It's a bit more complicated, but it is much more capable.

  Yes! SD interface enhance DFSD.
  But, for 1D data HDF file double in size.

  Suppose I have a 1D data of 10,000 values. 
  SD interface create a SDS (good!) [10,000] _AND_ a "fakedim" data
    [10,000] (?) also HDF content 20,000 values. I don't understand
    exact usage for "fakedim". For me:  array "fakedim" is
    a _big_ problem.
    consequence: I use DFSD interface :-(

Gilles Ratel
Email: [email-masked]

---

From: [email-masked] (Doug Ilg)
Date: 26 Jun 1995 13:46:12 GMT

[email-masked] (Gilles Ratel (8720)) writes:
|> 
|> Doug Ilg writes:
|> 
|> > Also, I would urge you to use the newer "SD" interface to HDF SDSs.  
|> > It's a bit more complicated, but it is much more capable.
|> 
|> 
|>   Yes! SD interface enhance DFSD.
|>   But, for 1D data HDF file double in size.
|> 
|>   Suppose I have a 1D data of 10,000 values. 
|>   SD interface create a SDS (good!) [10,000] _AND_ a "fakedim" data
|>     [10,000] (?) also HDF content 20,000 values. I don't understand
|>     exact usage for "fakedim". For me:  array "fakedim" is
|>     a _big_ problem.
|>     consequence: I use DFSD interface :-(

The 100% overhead on 1-D SDs is a problem that NCSA is looking into.  It's an
outgrowth of the merger of netCDF into HDF.  I don't know why, but apparently
it turned out to make sense in the netCDF context.

For that reason, when I need 1-D data, I use a vdata.  They are very efficient
and convenient for putting many variables into one structure.  The drawback
with vdatas is the lack of nifty general purpose visualization tools like you
get with SDSs (of either type).  C'est le vie, eh?

			-Doug