Subject: Re: Data Exchange in HTML

From: Evgenii Borisovich Rudnyi <[email-masked]>
Date: Tue, 23 Jan 1996 15:37:35 +0300 (GMT+0300)

Note that HTML is just a Document Type Definition in Standard
Generilized Markup Languige. Some references on SGML are below.

I am thinking on applying SGML for the thermodynamics data but I am only
at the starting point now.

Sincerely,

Evgenii Rudnyi
***********************************************************************
Chemistry Department       [email-masked] [email-masked]
Moscow State University    http://www.chem.msu.su/people/rudnyi/welcome.html
119899 Moscow              +(095)939 5452, fax+(095)932 8846, +(095)939 1205
Russia
************************************************************************

<DT><H3 ADD_DATE="804802322">sgml</H3>
<DL><p>
    <DT><A HREF="http://www.arbortext.com/wp.html" ADD_DATE="804802368" LAST_VISIT="804802291">All About ArborText</A>
    <DT><A HREF="http://www.auto-graphics.com/www/publishing/intrsgml.html" ADD_DATE="804807984" LAST_VISIT="804807683">An Introduction to SGML</A>
    <DT><A HREF="http://www.ileaf.com/sgmlguide.html" ADD_DATE="804808886" LAST_VISIT="804808872">The SGML Guide</A>
    <DT><A HREF="http://www.falch.no/~pepper/sgmltool/" ADD_DATE="804809209" LAST_VISIT="804809199">The Whirlwind Guide to SGML Tools</A>
    <DT><A HREF="http://www.csn.net/SGMLImplementationGuide/" ADD_DATE="804809325" LAST_VISIT="804809317">The SGML Implementation Guide Home Page</A>
    <DT><A HREF="http://gopher.sil.org/sgml/general.html" ADD_DATE="804810791" LAST_VISIT="804809399">SGML: Overview and General</A>
    <DT><A HREF="http://www.sq.com/sgmlinfo/glossary.html" ADD_DATE="805486021" LAST_VISIT="805486004">A Short SGML Glossary</A>
    <DT><A HREF="http://stardust.jpl.nasa.gov/mgddf/guidesgml.html" ADD_DATE="805486154" LAST_VISIT="805486147">Guide to Magellan Image Interpretation</A>
    <DT><A HREF="http://www.press.umich.edu/jep/" ADD_DATE="805486270" LAST_VISIT="806090694">JEP</A>
    <DT><A HREF="http://www.sq.com/sgmlinfo/primintr.html" ADD_DATE="806090487" LAST_VISIT="806090475">SGML PRIMER: Introduction</A>
    <DT><A HREF="http://www.sil.org/sgml/biblio.html" ADD_DATE="806090527" LAST_VISIT="806090520">SGML Bibliography</A>
    <DT><A HREF="http://www.sgmlopen.org/" ADD_DATE="806090612" LAST_VISIT="806090554">SGML Open Home Page</A>
    <DT><A HREF="http://www.ora.com/davenport/README.html" ADD_DATE="809299657" LAST_VISIT="809299627">Davenport Group Archive</A>
</DL><p>

---

From: [email-masked] (Thomas Gee)
Date: 30 Jan 1996 10:33:55 -0500

[E-mail posted with permission from Doug Ilg -- his news reader is flaky.]

Tom,

I would have posted this in sci.data.formats, but my news reader is
misbehaving.  By way of introduction, I'm a former NCSA HDF developer and
I'm still involved in HDF work through NASA's EOS project. 

> Ah, very nice.  I did do this, and received all the high-level description
> of the data file, but no image was produced (using xmosaic 2.7b2).

Yes, that's all you're gonna get.  Since the data is in an SDS, Mosaic
won't display it directly.  However, you can have Mosaic send the data to
another application via CCI or (in older versions) DTM.  I can give you
details on the DTM stuff, but not CCI.  Let me know if you're interested. 

BTW, if the data were in a raster image, Mosaic would have shown you a
[possibly subsampled] inline picture. 

> Does anyone know if Mosaic supports the Vset capability of HDF?  Using
> HDF3.3r3, Vset has been subsumed into HDF (as opposed to being an add-on
> package like it used to be), but you still end up using an entirely
> different API for manipulating them, so perhaps that part has not been
> implemented into Mosaic.

Vdatas and Vgroups (we don't use the term "Vsets" anymore) are completely
supported (sort of).  That is, the "Brows-o-rama" will display their
names, classes, field names, and data types, but doesn't display the data
itself.  A bit of a shortcoming :-)

If you want to display the contents of a Vdata in HTML, I'd suggest
exploring the HDF extensions to the NCSA httpd server program.  You can
see it at work at http://hdf.ncsa.uiuc.edu:4321/ It's currently at version
0.10a.  Many of the comments we gave NCSA about the original Mosaic HDF
capabilities were incorporated in the server-side version (many more
comments have been made since and we continue to work with NCSA on it).

> My test HDF file contains quite a number of Vset constructs, and when I 
> load one into Mosaic, it comes up with simply a blank screen.  I know the
> file format is HDF-compatible correct, because it is created entirely with
> HDF/Vset commands, and some programs (like hdfls) recognize its structure.

Your problem is most likely that your file dosn't have the required 
".hdf" extension.  Add that to the file name and see if magical things 
don't start to happen. :-)

[And it worked wonderfully! --tom]

		-Doug

====================================================================
Doug Ilg                                      Hughes STX Corporation
EOSDIS Standard Data Formats          7701 Greenbelt Road, Suite 400
[email-masked]                     Greenbelt, MD  20770  USA
Voice: (301) 441-4089                            FAX: (301) 441-1853
================= I do not speak for HSTX or NASA ==================