Subject: Re: Looking for tiled raster image format i/o libraries

From: [email-masked] (George Velamparampil)
Date: 17 Oct 1996 14:43:25 GMT

George Velamparampil ([email-masked]) wrote:
: Tom Spoering ([email-masked]) wrote:
: : I'm looking for library code for reading and writing tiled raster image data of 
: : multiple types (8, 16, 32 bit signed and unsigned int, 32 and 64 bit float) for 
: : very large (100s of MB) files.  Hopefully something in C or C++.  We need 
: : tiling for efficiency and also multiple images per file to store a pre-zoomed 
: : tier of resolution factors of the same image.
: : 
: : I've come across FITS and CCITT, but neither seem to fill all requirements.  
: : I've heard of TRIF, but haven't found a web page for it yet.
: : 
: 
: In HDF4.1 there will be support for chunking(2D-tiling) with compression
: using the Scientific Dataset(SDS) API. I don't know if the chunking will 
: make into the General Raster(GR) API by HDF4.1 release but I'm hoping it
: will. Currently the HDF4.1 release is scheduled for sometime in January or
: Febuary. A Beta release should be available in December.
: 
: I currently have a pre-beta release that has support for chunking without
: compression. If you are interested I can give you a copy. I have
: not settled on the final SDS API routines and would like to get some
: early feedback.
: 
: -georgev
: 
: -- 
: -----------------------------------------------------------------------------
: George Velamparampil  -- HDF Developer(mostly) -- email:[email-masked]
: Software Development Group -- NCSA -- University of Illinois, Urbana

I forgot to mention that another format the allows tiling and supports
the data types above is TIFF. 

The unofficial home page for TITF is 

  http://www-mipl.jpl.nasa.gov/~ndr/tiff/

The home page for HDF is 

  http://hdf.ncsa.uiuc.edu/

-georgev

-- 
-----------------------------------------------------------------------------
George Velamparampil  -- HDF Developer(mostly) -- email:[email-masked]
Software Development Group -- NCSA -- University of Illinois, Urbana

---

From: [email-masked] (George Velamparampil)
Date: 16 Oct 1996 23:06:38 GMT

Tom Spoering ([email-masked]) wrote:
: I'm looking for library code for reading and writing tiled raster image data of 
: multiple types (8, 16, 32 bit signed and unsigned int, 32 and 64 bit float) for 
: very large (100s of MB) files.  Hopefully something in C or C++.  We need 
: tiling for efficiency and also multiple images per file to store a pre-zoomed 
: tier of resolution factors of the same image.
: 
: I've come across FITS and CCITT, but neither seem to fill all requirements.  
: I've heard of TRIF, but haven't found a web page for it yet.
: 

In HDF4.1 there will be support for chunking(2D-tiling) with compression
using the Scientific Dataset(SDS) API. I don't know if the chunking will 
make into the General Raster(GR) API by HDF4.1 release but I'm hoping it
will. Currently the HDF4.1 release is scheduled for sometime in January or
Febuary. A Beta release should be available in December.

I currently have a pre-beta release that has support for chunking without
compression. If you are interested I can give you a copy. I have
not settled on the final SDS API routines and would like to get some
early feedback.

-georgev

---

From: Phil Keslin <[email-masked]>
Date: Wed, 16 Oct 1996 16:18:34 -0700

Tom Spoering wrote:
> 
> I'm looking for library code for reading and writing tiled raster image data of
> multiple types (8, 16, 32 bit signed and unsigned int, 32 and 64 bit float) for
> very large (100s of MB) files.  Hopefully something in C or C++.  We need
> tiling for efficiency and also multiple images per file to store a pre-zoomed
> tier of resolution factors of the same image.
> 
> I've come across FITS and CCITT, but neither seem to fill all requirements.
> I've heard of TRIF, but haven't found a web page for it yet.

Have you checked out TIFF? It supports all of the features that you
require. The source for the library is readily available from the
following URL.

ftp://ftp.sgi.com/graphics/tiff

There is a README and HOWTO file that contain lots of information.

Hope this helps...

- Phil

-- 
Phil Keslin			Silicon Graphics, Inc.
E-Mail: [email-masked]	2011 N. Shoreline Blvd. M/S 8U-590
Phone: (415)933-1959		Mountain View, CA 94043