Subject: Re: image format

From: [email-masked] (ATTILA KONKOL)
Date: 26 Apr 94 14:04:29 BST

In article <[email-masked]>, [email-masked] (Tianyun Ma) writes:
> Are there any books to describe the format of the image files, like GIF, TIFF,
> BMP , etc.
> 
> I mean, if I know the brightness and locations of a bunch of pixels, how can
> I generate a GIF file that can be displayed via XV?
> 
> Thank you!

Steve Rimmer: Bitmapped Graphics
Windcrest Books, Blue Ridge Summit
ISBN 0-8306-8558-8

There is an advanced version of this book
with similar title.

Regards
Attila

---

From: [email-masked] (Torsten Ihle)
Date: 26 Apr 1994 16:39:49 GMT

In article <[email-masked]> [email-masked] (Tianyun Ma) writes:

> Newsgroups: sci.image.processing
> Path: uwvax!uwm.edu!cs.utexas.edu!swrinde!gatech!newsxfer.itd.umich.edu!gumby!yale!cs.yale.edu!tma
> From: [email-masked] (Tianyun Ma)
> Sender: [email-masked] (Usenet News)
> Nntp-Posting-Host: tuna.zoo2.cs.yale.edu
> Organization: Yale University Computer Science Dept., New Haven, CT 06520-2158
> X-Newsreader: Tin 1.1 PL5
> Date: Tue, 26 Apr 1994 02:58:06 GMT
> Lines: 7
> 

My apologies to all netters, but this guy's email-address is unreplyable, so I have to post it.

Hi,

there are even sites somewhere describing image formats
(e.g. wuarchive.wustl.edu in the graphics/formats ), and I this
question has been answered a lot in s.i.p. Just look in the archive of
this newsgroup.

BUT, you don't need to know the formats, since there are zillions of
programs out there converting from one to another. Suitable for your
purposes would be the pbmplus package (ask archie for it, or maybe it
is already installed), there is a program called rawtopgm
included. (Enclosed is the man page). You can read pgm-files with xv.

rawtopgm(1)         UNIX Programmer's Manual          rawtopgm(1)

NAME
     rawtopgm - convert raw grayscale bytes into a portable gray-
     map

SYNOPSIS
     rawtopgm [-headerskip N] [-rowskip N] width height [image-
     data]

DESCRIPTION
     Reads raw grayscale bytes as input.  Produces a portable
     graymap as output.  The input file is just grayscale bytes.
     You have to specify the width and height on the command
     line, since the program obviously can't get them from the
     file.  The maxval is assumed to be 255.  If the resulting
     image is upside down, run it through pnmflip -tb .
...
----------------------------------------------------------
Torsten Ihle, Dipl. Inform., Univ. Special & Int. Student,
University of Wisconsin, Madison
EMail: [email-masked]

Die Schweine von heute sind die Schinken von morgen !
----------------------------------------------------------
--
----------------------------------------------------------
Torsten Ihle, Dipl. Inform., Univ. Special & Int. Student,
University of Wisconsin, Madison
EMail: [email-masked]

Die Schweine von heute sind die Schinken von morgen !
----------------------------------------------------------